Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
PowerHome General
 PowerHome Messageboard : PowerHome General
Subject Topic: Funky IR Code Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 872
Posted: March 22 2019 at 12:37 | IP Logged Quote GadgetGuy

I just bought a small sound server (FM/SD
Card/Bluetooth/Aux) amplifier for my whole house
ceiling speaker music system.

Lepai Model LP-269FS.

It has a IR Remote to also control the amp and I want
to use the IR link with PH to mute the amp when the
home theater system is started up.

BUT, in Learning the remote's MUTE IR Code what I get
in pronto format is "0000 006D 0000 0000"

I consistently get that code using either the USB-
UIRT, or the Global Cache IR transponders.

Unfortunately, PH does not recognize that code so it
must be unique to this Chinese designed and made audio
device.

Is there a way to send that code from PH?

I assume if the IR transponders can received and
decode that sequence it can send it back out if I can
just get it to them.


__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 872
Posted: March 23 2019 at 08:13 | IP Logged Quote GadgetGuy

Probing the USB-UIRT settings I rediscovered the "uirtraw" capture setting and grabbed the raw IR stream and saved that in my IR Devices configuration settings as seen in the top part of the image below.



The bottom part of the image shows that an Outgoing IR command can be successfully sent and that the Incoming IR command received from the Remote matches exactly the code I believe I am sending out.

BUT the target device does not respond at all. I tried <repeat>3 with no effect. The raw code I receive matches repeatedly when sensing with both the UIRT and Global Cache IR units I have, and using the UIRT Ap gives me the same results as what PH sees for the code received from my remote. Thus it appears I have the right code, but I can't seem to get it to work.

Anyone have any debugging thoughts to share?   


__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 
HarrySaw
Newbie
Newbie
Avatar

Joined: May 24 2019
Location: United States
Online Status: Offline
Posts: 4
Posted: May 29 2019 at 16:50 | IP Logged Quote HarrySaw

I see. Thanks for the tip, GadgetGuy!
Back to Top View HarrySaw's Profile Search for other posts by HarrySaw
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum