Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
PowerHome General
 PowerHome Messageboard : PowerHome General
Subject Topic: PLM Stuck in Delete Loop Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
renard
Groupie
Groupie
Avatar

Joined: November 01 2009
Location: United States
Online Status: Offline
Posts: 59
Posted: October 07 2021 at 12:38 | IP Logged Quote renard

PH managed to invent a non-existent device with no type and an address of 1c.2c.d4. I removed the non-existent device and now PH is stuck in a loop trying to delete the responder link in the PLM. I have cleared the PLM and reloaded the link structure and it just loops continuously. I need to kill the Pending Operation list. How do I do that?

BTW- when is the new version of PH going live. I am desperate to replace the wonky Insteon thermostat with a Z-Wave one.

Thanks,

Terry

__________________
Terry
Back to Top View renard's Profile Search for other posts by renard
 
renard
Groupie
Groupie
Avatar

Joined: November 01 2009
Location: United States
Online Status: Offline
Posts: 59
Posted: October 07 2021 at 16:05 | IP Logged Quote renard

If purging the Pending Operations list has undesirable implications, then put a limit on DELETE LINK failures. At present, with a 1 second Poll Interval, the DELETE LINK has failed for more than an hour and no other link charges are getting processed.

Terry

__________________
Terry
Back to Top View renard's Profile Search for other posts by renard
 
dhoward
Admin Group
Admin Group
Avatar

Joined: June 29 2001
Location: United States
Online Status: Offline
Posts: 4372
Posted: October 19 2021 at 22:46 | IP Logged Quote dhoward

Terry,

To clear a "stuck" link, go to the "Links" tab of Insteon Explorer, highlight the link and then press the "Remove" button (or drag and drop the link onto the
Remove button). This will just remove the bad link from the database without actually trying to communicate with non-existent devices. I'll also look at the
code to see if I can put some kind of timeout on this type of functionality. I thought I had already done that but might not have covered every possibility.

PowerHome 2.2beta3 is available on the forum and has support for Z-wave but only the Razberry Z-wave daughterboard for the Raspberry Pi. Im planning on adding
support for the USB Z-wave sticks using the Open-Zwave library but havent even had a chance to start on that yet.

Dave.
Back to Top View dhoward's Profile Search for other posts by dhoward Visit dhoward's Homepage
 
renard
Groupie
Groupie
Avatar

Joined: November 01 2009
Location: United States
Online Status: Offline
Posts: 59
Posted: October 30 2021 at 09:30 | IP Logged Quote renard

Dave,

Thanks, REMOVE worked perfectly. Regarding PH 2.2, I am in general reluctant to put a beta version into production. Is beta3 really the very near release version of PH 2.2?

I realize that the global chip and logistics issues we are seeing are important but I think Smarthome, the sole-source for Insteon devices, is at least de-emphasizing Insteon devices as many types other than wall switches are 'out of stock'. I think we need to migrate away from Insteon as quickly as possible to Z-Wave.

__________________
Terry
Back to Top View renard's Profile Search for other posts by renard
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum