Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
PowerHome General
 PowerHome Messageboard : PowerHome General
Subject Topic: getURL Issue Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 885
Posted: January 27 2022 at 17:40 | IP Logged Quote GadgetGuy

For several years I have been fetching my outside temps from my TempStick (https://tempstick.com/) which produced a (normal) web page with text and html formatting.

But months ago they changed the site from a 50,000 character site to a 400 character site by creating a single Home page comprised of almost nothing but links.


While the link collection produces a viewable web page the ph_geturl1() function sees nothing and I am unable to thus extract any meaningful temp data.

Is there a PH URL function or configuration of one that will process the raw page into the user viewable form see when you access it as a web page which looks like this...


Any ideas of how I can regain this weather page feed?

Gadget Guy

__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 719
Posted: January 28 2022 at 19:37 | IP Logged Quote smarty

Outside my skill set - but following to see any answers....

__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 885
Posted: January 28 2022 at 19:55 | IP Logged Quote GadgetGuy

Smarty -

I figured Dave will probably have to see and answer this.
:-) gadgetGuy


__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 
dhoward
Admin Group
Admin Group
Avatar

Joined: June 29 2001
Location: United States
Online Status: Offline
Posts: 4384
Posted: February 02 2022 at 18:28 | IP Logged Quote dhoward

Ken,

Likely what has happened is that they've updated the site to pull various portions back in iframes or similar. Whenever you hit a webpage, the HTTP
is retrieved which can potentially include links to images, javascript, iframes, cascading style sheets, etc. A standard browser will interpret the
initial HTTP, scan it for these other links and sequentially pull those other URL's and render them in the browser window.

Im not certain of the exact URL you are using but the actual data you're interested (probably sensor data) should be in one of the links that is
coming from the main URL. If you could send me the actual 400 byte return data from the ph_geturl1 function, I may be able to determine something
else for you to query on.

An option you can try is using the ph_getwburl function. This function uses the (now ancient) Internet Explorer web browser control to pull the sql.
Theoretically, it should be able to pull down the full HTML that is used to render the page since it's an actual web browser. The only problem I see
is that it is likely too old to understand the newer HTTP protocol so may not work properly. The newest versions of PowerBuilder (the language
PowerHome is developed in) include a new, updated Chromium web browser control that I plan to implement which may end up providing a solution (no
timeframe available on when I'll have that ready though).

Anyways, if you can post the 400 byte return of ph_geturl1, I should be able to determine a possible solution for you.

Dave.
Back to Top View dhoward's Profile Search for other posts by dhoward Visit dhoward's Homepage
 
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 885
Posted: February 03 2022 at 13:02 | IP Logged Quote GadgetGuy

Thanks Dave -

Please find attached a scrape via URL1 and an image of what appears on my computer screen via MS Edge browser. Note the two captures where taken a few minutes apart so specific variable values may not match.

2022-02-03_130158_wthrStik - URL1 Scrape.txt



gadgetGuy


__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum