Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
PowerHome General
 PowerHome Messageboard : PowerHome General
Subject Topic: Dave Questions Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
GadgetGuy
Super User
Super User
Avatar

Joined: June 01 2008
Location: United States
Online Status: Offline
Posts: 896
Posted: April 06 2022 at 12:09 | IP Logged Quote GadgetGuy

Dave -
Were you ever able to figure out a way to URL Scrape the Temp data from my TempStick's (https://tempstick.com/)strange indirect data references?

Also I have been stumped/frustrated for a year by my inability to access the PH web server every time Microsoft downloads a new update. I can't figure out what they screw up but if I horse around with Sharing, Media Server enables, firewalls, and malware blockers I can usually get it working again, but not for the last 2 months at all.

I can't even access the PH web site from the "web" icon in the link icons at the top of the PH desktop window.

Any thoughts, on what it might be? From another computer on my network I can view a .jpg file in the web folded of PH, but can not execute any .html files.

VERY frustrating.


__________________
Ken B - Live every day like it's your last. Eventually, you'll get it right!
Back to Top View GadgetGuy's Profile Search for other posts by GadgetGuy
 
dhoward
Admin Group
Admin Group
Avatar

Joined: June 29 2001
Location: United States
Online Status: Offline
Posts: 4399
Posted: April 11 2022 at 17:34 | IP Logged Quote dhoward

Ken,

I did not get a chance to look very deep into the web scraping issue. I'll look for the post and see what I can come up with.

Concerning the webserver, Im not sure why that would be. I have Windows updates turned off on my PH machine so Im probably not a good litmus test but I would
suspect it has something to do with the firewall and such. The fact that you can pull a .JPG file tells me the webserver is working so not sure why it wouldnt
pull a .HTML file unless some Microsoft security (or 3rd party) is kicking in.

Im still running Windows 7 but I imagine you may be on Windows 10 if you're getting that many updates. I wouldnt rely on the web icon in the PH toolbar as that
is still using the Internet Explorer activex control which is probably going to completely stop working in June if I have my dates correct. I have it on my
todo list to rewrite it using the new Chromium control that is now available in PowerBuilder.

A few things to try though with your webserver. In the pwrhome.ini file under [WebServer] section, there are a couple of relatively new parameters
webservertype and webserveroptions. The default is webservertype=2, webserveroptions=1 and that will change the webserver to using a new webserver activex
control that I wrote using Visual Studio. It's what I use in my setup but I know some people were having some problems. The old, original webserver which uses
a Catalyst socket control is available by setting both webservertype and webserveroptions to 0. Remember, anytime you make changes to the INI file, you'll need
to save and either restart or reinit PH.

The last thing you can try is setting the webservertype=1. This is using a Catalyst Internet server control. I didnt think it worked very well but some users
say it's what works the best for them. In any event, the problems may be related to one or more of the controls not being properly registered or potentially
blocked by MS or a 3rd party so I would give all 3 types a go. If the problem is still the same with all 3 options and you cant access the webserver from the
PH machine itself, it's almost certainly something to do with MS security, firewall, or a 3rd party app. I would first start with 1 by 1 disabling 3rd party
apps such as anti-virus and the like. Work your way up the firewall. Not sure if the Windows eventlogs will have any information but it wouldnt hurt to check.

Hope this helps,

Dave.
Back to Top View dhoward's Profile Search for other posts by dhoward Visit dhoward's Homepage
 
dhoward
Admin Group
Admin Group
Avatar

Joined: June 29 2001
Location: United States
Online Status: Offline
Posts: 4399
Posted: April 11 2022 at 17:40 | IP Logged Quote dhoward

Ken,

Just thought of some other possibilities. Check your pwrhome.ini file under the [WebServer] section and see how far off your settings below are from mine:

AUTHMODE=1
COOKIEPERSISTDAYS=30
ENABLEWAP=NO
WEBSERVERUSESSL=NO
WEBSERVERCERTNAME=
WEBSERVERDIRECTORY=c:\powerhome\web
WEBSERVERALLOWGUEST=NO
WEBSERVERSECPSP=2
WEBSERVERSECHTM=0
WEBSERVERSECGIF=2
WEBSERVERSECJPG=2
WEBSERVERSECOTHER=2
TRUSTEDIPS=127.0.0.1;192.168.0.*
BLACKLISTIPS=
ENABLESMARTNEXTURL=NO
ENCODING=UTF-8
headerincludefile=c:\powerhome\headerinclude.txt
ccheaderincludefile=c:\powerhome\ccheaderinclude.txt
ccmapheaderincludefile=c:\powerhome\ccmapheaderinclude.txt

You can see that the WEBSERVERSECJPG parameter is set to 2 which means that no login to the PH server is necessary. The WEBSERVERSECHTM=0 means that you
must have admin (not guest) access in order server HTM files and I believe the internal CGI. Also check that you don't have BLACKLISTIPS that might be
preventing access.

Dave.
Back to Top View dhoward's Profile Search for other posts by dhoward Visit dhoward's Homepage
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum