Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
PowerHome Bug Reports
 PowerHome Messageboard : PowerHome Bug Reports
Subject Topic: ph_getitcurl not working...fresh install Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 723
Posted: December 17 2015 at 07:24 | IP Logged Quote smarty

...I am going back to Win7 32, Home Premium...
=========================================
PH formula in question:
ph_getitcurl("http://{IP_TSTAT-LIV}/tstat",5)

Response:
Internal Formula Error
     An internal error occurred while running the formula. Please report
the error details below to PowerHome.
*** Error Details ***
Error Number: 39
Object Name: uo_itc
Class: uo_itc
Routine Name: constructor
Line: 1
Text: Error accessing external object property accesstype at line 1 in
constructor event of object uo_itc.

=================================
Note - I had my boot disk crash earlier this week.
I have re-installed Win 7, but now using the 64 bit version (prior was the
32 bit system).

I think I have my PH and the operation system back to the level they
were at prior to the crash.

Edited by smarty - December 21 2015 at 11:03


__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 723
Posted: December 19 2015 at 18:15 | IP Logged Quote smarty

OK - back to a Win7 32 bit system - full, clean install. All updates done to Win7, and running PH2.1.5d.

Good news is that almost all appears to work...EXCEPT for the ph_getitcurl() function..... (that I use to get information from my Radio thermostats).

Rightly (or wrongly) I did go back and run regsvr32 on

cshtpax6.ocx
csicmax6.ocx
csmsgax6.ocx
csrasax6.ocx
csmtpax6.ocx
cswsvax6.ocx

as mentioned in this post

Link

except that all the files are now zzzzzax8.ocx (version 8 instead of 6?). Still no luck.

I have Win7 32 on my developmental box, and the ph_getitcurl() function works fine there.

I can't find any differences between Windows7, PH or IE11 between the two machines.

What might I be missing?

__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 723
Posted: January 03 2016 at 20:56 | IP Logged Quote smarty

Anyone?

__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 
BeachBum
Super User
Super User
Avatar

Joined: April 11 2007
Location: United States
Online Status: Offline
Posts: 1880
Posted: January 03 2016 at 21:39 | IP Logged Quote BeachBum

You must have something foreign to PH as I tested your formula and had no problem with win64 bit. Just a stab in the dark but have you run phupg?

__________________
Pete - X10 Oldie
Back to Top View BeachBum's Profile Search for other posts by BeachBum
 
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 723
Posted: January 04 2016 at 10:53 | IP Logged Quote smarty

Thanks for the suggestion Pete.

Just tried it...database rebuild was uneventful... Rebuilt database still gives me the same error :(

__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 
dhoward
Admin Group
Admin Group
Avatar

Joined: June 29 2001
Location: United States
Online Status: Offline
Posts: 4430
Posted: January 04 2016 at 20:28 | IP Logged Quote dhoward

Steve,

PowerHome 2.1.5d uses the version 8 of the Catalyst
controls zzzzzax8.ocx. However, the ph_getitcurl does
not make use of any of the Catalyst controls and
instead uses the Microsoft Internet Transfer Control
which is file msinet.ocx (should be in
c:\windows\system32 on Windows 7/32). Check to make
sure the file exists and try running regsvr32 on it if
it does.

Let me know how it goes.

Dave.
Back to Top View dhoward's Profile Search for other posts by dhoward Visit dhoward's Homepage
 
smarty
Super User
Super User
Avatar

Joined: May 21 2006
Location: United States
Online Status: Offline
Posts: 723
Posted: January 05 2016 at 09:32 | IP Logged Quote smarty

Dave,
    That file is not on my fresh install (anywhere). Very odd. I will copy it from my other machine into system32 and register it. I will let you know how it goes...

Update...
After copying that file off another (older Win 7 x32 machine), and placing in the system32, then registering it....all now works (thank you Dave).

However - that file was NOT natively installed on my Win7 fresh install. Maybe this file will need to be included with new versions of PH?


Edited by smarty - January 05 2016 at 10:55


__________________
Elk - Insteon - BlueIris - DMC1 - PowerHome - XLobby - HA_Bridge w/Dots - Brultech
Back to Top View smarty's Profile Search for other posts by smarty
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum